Home Forums Pure Theme Discussion & Support Version 1.7 released

This topic is: not a support question

This topic contains 18 replies, has 4 voices, and was last updated by  themeweaver 4 years, 9 months ago.

Viewing 15 posts - 1 through 15 (of 19 total)
  • Author
    Posts
  • #2356

    themeweaver
    Keymaster
    Post count: 730

    Resolved issued with 1.5 and 1.6 which broke the responsive part of the theme.

    IMPORTANT: because 1.5 included a major update to the themeloom widgets, it is a good idea to go into any instances of the widgets and re-save each one you are using in Appearance-Widgets

    Oh and we added a Google plusone button to the share buttons.

    #2374

    kam onn siew
    Participant
    Post count: 12

    all images are magnified in Version 1.7 ?
    Check out http://wpstage.standrewschurch.org.my/.

    Note in particular the footer icon.

    #2376

    themeweaver
    Keymaster
    Post count: 730

    Did you do the IMPORTANT step above?

    I.e. go into each instance of the widgets and hit save on each one.

    The new widgets let you choose different images sizes but for best results always choose “widget” in this theme. But you MUST re-save widgets after the upgrade.

    #2377

    kam onn siew
    Participant
    Post count: 12

    this too seems peculiar to only IE 8.

    I checked out wpstage.standrewschurch.org.my on Chrome, IE on my Windows 7 machine and the website rendered normally.

    #2378

    kam onn siew
    Participant
    Post count: 12

    With version 1.4, IE 8 did not display the gigantic images.

    #2379

    themeweaver
    Keymaster
    Post count: 730

    Have you gone into each widget and clicked save? if not do so.

    #2380

    kam onn siew
    Participant
    Post count: 12

    I did.
    I checked on several other machines with IE8 and they all have the same magnified images.
    On those same machines, I tested Firefox and the images were normal sized.

    While the other images’ sizes might be subjective, the footer icon size is hard to ignore. I don’t have a widget in the footer area.

    #2381

    themeweaver
    Keymaster
    Post count: 730

    OK, I think I found this, but this should have also been a problem in 1.4 too.

    Anyway if you want to try a fix:

    1. open the file \base\css\ie.css

    2. change last line to

    img,object {width: auto\9; /* ie8 */}

    instead of width:100%! –

    #2388

    kam onn siew
    Participant
    Post count: 12

    yep, that fixed it

    #2389

    kam onn siew
    Participant
    Post count: 12

    I deployed 1.7 to my live site and started getting HTTP 500.
    Since I did not get the same on the staging site, I believe one of my plugins is interfering with the updated theme files.
    My web hoster says my latest update caused memory limit breaches.

    I flipped back to 1.4.
    I would like to troubleshoot the plugins by disabling some plugins, flip to 1.7, repeat until I find the error.
    Each time I do the flip now, I upload 458 files and I have to do in intervals because my web hoster complains that my filezilla session is sending too many sessions.

    I need your help to find out the files that changed between 1.7 and 1.4 – so that I only upload those files.

    #2390

    Richard
    Participant
    Post count: 181

    Out of curiosity, did you also upgrade to WP 3.3? And, if so, are all your plugins compatible?

    #2391

    kam onn siew
    Participant
    Post count: 12

    I have not upgraded to wp3.3 on both wpstage and the live sites.

    #2392

    Richard
    Participant
    Post count: 181

    Okay – just thought I would see if that might be a helpful avenue of consideration :)

    #2393

    themeweaver
    Keymaster
    Post count: 730

    Files changed between 1.7 and 1.4 include:

    style.css
    header.php
    \base\content.php
    \base\functions.php
    \base\lib\* (or nearly all)
    \base\css\reset.css
    \extend\scripts.php

    This is quite a lot but most is in common with other themes (part of the framework).

    BUT the theme will not work if you only upload parts of these changes. Most of the changes to php files were to update the way the theme loads css styles. So not uploading one of the files would break the theme.

    If you want to eliminate the theme from the cause of your errors, disable all plugins and test your site. But this code is running on many sites without a problem.

    From the sound of things you either have a problem with your WordPress install, plugins or even with your host server itself. With regards ftp have you tried setting “Limit number of simultaneous connections” option or perhaps changing any firewall settings.

    #2403

    Jordi Artal
    Member

    The issue with the large images has been a problem since 1.0 — it only occurs in compatability mode on IE9 or on older browsers. A similar issue, which I’m not sure has been fixed, is that in these older browsers or in compatability mode, all the text is centered.

    While on the topic — I think there might be a DOCTYPE or CSS issue because really if the HTML and CSS are clean, IE9 should not even offer the option of compatability mode. Go to, say, google.com and you’ll see that the browser doesn’t even display the compatibility icon.

Viewing 15 posts - 1 through 15 (of 19 total)

You must be logged in to reply to this topic.