Home Forums Mint Theme Discussion & Support Troubles with “Add Friend” / “Cancel Friend Request” buttons

This topic is: resolved

This topic contains 9 replies, has 2 voices, and was last updated by  themeweaver 3 years, 12 months ago.

Viewing 10 posts - 1 through 10 (of 10 total)
  • Author
    Posts
  • #3626

    Max CM
    Member
    Post count: 21

    Hi again,

    With the theme, when I “add a friend”, the button immediately disappear or sometimes changed to “Cancel Friend Request” as intended but when I refresh the page, it shows “Add Friend” again and nothing has happened.
    When (a couple of times) “Cancel Friend Request” appeared, the other member received the notification but nothing happened when you clic on “Accept” and the request is pending for ever.

    The “Add a friend function” works perfectly with the default theme of buddypress.

    And I already deactivated all the plugins to be sure it’s not one of them. The only thing it made is that when I “Add a friend”, the button doesn’t disappear for leaving a blank but for showing a page in a page… (with all the links transformed to basic big black buttons)

    Any suggestions to fix this?

    Thanks !
    Max

    #3629

    Max CM
    Member
    Post count: 21

    …this is so important and so urgent as you might guess…!

    Thanks for your time and skill.

    Max

    #3634

    themeweaver
    Keymaster
    Post count: 730

    We haven’t come across this issue anywhere else.

    I have just registered on your site as a new user to see what you mean. There does appear to be an issue on your site.

    To try and work out what the problem might be I would need access to your WP dashboard.

    #3637

    Max CM
    Member
    Post count: 21

    Thanks !

    Your account is now an admin.
    Of course, no need to tell you this, I know, but please be carefull… 😉

    I hope you will find what is going on. As you will see, I have a child theme with a functions.php in it…

    #3638

    themeweaver
    Keymaster
    Post count: 730

    First look suggests this is some kind of permissions issue.

    I created a second user which is unable to work. But my admin user works fine.

    So it seems that only admins can be friends!

    I don’t want to dig any more without your permission, but I would suggest the configuration or plugins are stopping the ajax script working. I know you say you have tried this but I would disable all plugins apart from buddypress.

    I am surprise that the default theme works, because all our themes pull in the javascript that handles this from the default theme.

    If you want to me to look further let me know, but I would like to switch the dashboard to English to do so, as it makes life a little easier for me. My French is very bad.

    #3639

    Max CM
    Member
    Post count: 21

    You can dig my friend, you can dig ! I have a recent backup of everything…

    That’s what I guessed, only admins can be friends. I didn’t check properly if they can add each other for real though but I know admins receive the notifications.

    You can turn it into english and buddypress too if you need to.

    If you disable plugins, just don’t activate back these ones (useless or not compatible) :

    Advanced Access Manager
    BuddyPress Friends On-line (FOL)
    BuddyPress Like
    Follow
    Google WebFonts Integrate
    Google Web Fonts Manager
    Po.st
    Really simple Facebook Twitter share buttons
    Site Layout Customizer
    Wapple Architect
    WP Google Fonts
    WP Super Cache

    Thanks a lot !

    Also, I would prefer not to do that, but if we can’t fix the issue, would that be a security problem if I have to set all users to “admins” and forbid the access to the dashboard to them as I did for “authors” now, me being a super admin ?
    I don’t like this idea, but if it can’t be solved… (?)

    #3640

    themeweaver
    Keymaster
    Post count: 730

    No you won’t need to set users to admins. this works for ordinary users on all the other sites I have worked on. Something in your setup is blocking the friend ajax action.

    I wil try and take a look later.

    #3641

    Max CM
    Member
    Post count: 21

    Ok Tim. Don’t hesitate to ask if you need something from me.

    Thanks, have fun ! 😉

    #3657

    Max CM
    Member
    Post count: 21

    Hi again !

    Did you have time to have a look on this issue ?
    Please let me know when you do it.
    …Coz I can’t lunch the website without it.

    Thanks again.
    I hope to talk to you soon.

    #3658

    themeweaver
    Keymaster
    Post count: 730

    Max,

    Yes tried some digging. I tried changing the theme to the Mint parent theme, and now getting server error.

    Without further access to the site I am unable to fix this.

    You may need to remove the Mint theme folder temporarily via ftp to force wp back to default theme to get the site running again. Then re-download and install.

    I could do with ftp access to dig deeper. You can use the priority contact form to get in touch via e-mail and we can go from there.

Viewing 10 posts - 1 through 10 (of 10 total)

You must be logged in to reply to this topic.