Home Forums Xi Theme Discussion & Support Activity Stream limited to 20 posts in Groups

This topic is: not a support question

This topic contains 4 replies, has 2 voices, and was last updated by  Cam Collins 3 years, 8 months ago.

Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
    Posts
  • #3720

    Cam Collins
    Participant
    Post count: 8

    Hi all!

    Having an issue whereby the number of posts in any given activty stream within a group is limited to 20 posts. When I click “load more” no further posts get displayed. But when I go to the main activity stream I see many more posts that are “attributed” to the group in question. I looked at the following:

    http://codex.buddypress.org/developer/developer-docs/loops-reference/the-activity-stream-loop/

    The accepted parameters for the bp_has_activities() activity loop that I looked at were:

    “max” and “per_page”

    “max=100” in every instance in the Xi theme
    “per_page=15” in ./themes/LivingOS_Xi/groups/single/admin.php

    I changed per_page to 150 with little hope of it changing something because 20 posts are being displayed. I believe this limits the number of groups in the “Group” listing.

    Thoughts?

    #3721

    themeweaver
    Keymaster
    Post count: 730

    Do yo have a url?

    Most likely cause is the javascript that pulls in additional posts is not working on your site. Could be a conflict with plugins. But let us have a url and we can have a look.

    #3722

    Cam Collins
    Participant
    Post count: 8

    The URL is http://birdhero.com. I have created a user for you to access the “member” section.

    REMOVED!

    #3723

    themeweaver
    Keymaster
    Post count: 730

    Sorry i removed the username/password. you shouldn’t post that in the forum!!

    Use the Support contact form instead if you need send stuff you don’t want others to see. Delete the user you created and create me a new one if you need to.

    Anyway a quick look at your site suggests as I said there are a few javascript errors. Use your browser, e.g. Chrome and open developer panel. View the console tab and you will see a few issues going on.

    Mostly it looks like plugins related to teh social network feature, like facebook etc.

    Disable all plugins and work through until you find the culprit.

    http://themeloom.com/support/priority-support/

    #3724

    Cam Collins
    Participant
    Post count: 8

    User only had Subscriber privileges but Ok…changed it. Will move this thread to Priority Support board.

Viewing 5 posts - 1 through 5 (of 5 total)

You must be logged in to reply to this topic.